Host removes useartwork 1 from cfg file.

Hello there.
I want to use custom models in a server I've been developing.
Problem? I set all models & artcfg file correctly in the models folder, but when I add 'useartwork 1' to the server.cfg file the host CP automically removes it, because it's still a 0.3.7 CP. I'm running 0.3.DL tho.

Is there someway I can get around? without having to contact the host?

Yes there is a way, get a new host, no other way to get around it.

Try SendRconCommand("artwork 1"); in OnGameModeInit (not sure if works)

Originally Posted by userid
View Post
Try SendRconCommand("artwork 1"); in OnGameModeInit (not sure if works)
I think the models load before OnGameModeInit is processed, hence, not having artwork set to 1 is going to prevent the models from loading (I think) But hey you can always give it a shot.

I believe any reasonable game host (of any kind) gives you FTP access to your own server.

You could hope that the CP enforces It's settings (ports/slots) when you finish editing.
you can try modifying the cfg file using your FTP access.

If that doesn't work as well, that probably means the CP enforces settings on server start and there's no way around it other than having the host enable that for you.

Most of hosts do this to prevent people from over-using their service.
(i.e adding more slots to themselves, switching ports, etc

All around, I would recommend buying a VPS and managing it.
Some providers offer a variation of servers (including ones running windows operating system) for decent prices not to mention It's actually fun to try something new and be in control of everything yourself.

Good luck!

I contacted the host and they've set useartwork to 1. I loaded the models correctly in the models folder and adjusted the artconfig file. Still they do not download upon joining the server.


Seems like it sometimes forces download on players, sometimes it doesn't.
Now they get loaded, but after a GMX they do not anymore.

EDIT; Solved.

Forum Jump:

Users browsing this thread: 1 Guest(s)