Can't start up gta_sa.exe

Before explaining, i want to clear up that i'm running Windows 10.

So a few days ago i was working on my own gamemode, actually editing the map with map editor, and i notice something rather strange, when i wanted to test out my map, San Andreas wouldn't start up.
I didn't know why that was, but i figured it could be just a bug of the editor, so i kept going. Though a few days later when i wanted to log into my SAMP sever, gta_sa.exe wouldn't start up.

It was weird, so i decided to check the singleplayer version, and this time it did start up, but it would freeze when the nVidia logo would start to fade. That always happens when you start up San Andreas, it freezes for half a second on the nVidia logo fading, but this time it took way longer and i realized the game was actually frozen. I alt-tabbed, ctrl-alt-deleted my way to the task manager and tried to task kill SA's process, but when i pressed "End task" nothing would happen. I went to the details section and tried to end the process, but it would tell me "Access denied", which was really fucking weird because San Andreas never did that before.

So, seeing as Task Manager wasn't working, i decided to run the command terminal as administrator, using the taskkill comand.
After typing in taskkill /F /IM gta_sa.exe expecting it to be terminated, the terminal said this:

ERROR: The process with PID 5736 could not be terminated.
Reason: There is no running instance of the task

I tied killing it several times but to no avail. I couldn't kill the process, even signing out of my Windows profile, which kills all processes, didn't shut it down. The only way i could get SA's process to end was to restart my computer.
I figured maybe the .asi files or cleo stuff messed with my copy of it so i thought i'd just re-download it and install a fresh copy, which is what i did today, i had a completely different install of San Andreas and ran it expecting my problem to be fixed, but nope, i had the same results today, AND WITH A COMPLETELY DIFFERENT FRESH INSTALL.

Currently the process is still running, i think i'm going to restart my computer in a few mins because i don't want it to pointlessly soak up my memory, but if any of you know how to fix my problem, i request your help. I'm very passionate about coding for SAMP and just seeing my work vanish like this really sucks.

Delete (gta_sa.set) file and test it again
My Documents >>> GTA San Andreas User Files >>> gta_sa.set

You may need Marty McFlys ENB 0.248 version Win 8 fix.

Run that batch file as admin. All it's doing is setting registry settings that seem to be a problem with some installs of Windows 10.

The game works once, then just refuses to start for any real reason. Only on windows 10, and seemingly like this.

Forum Jump:

Users browsing this thread: 1 Guest(s)