Not sure what this is - Error with my script or host issue?

So what i'm having issues with is that none of my .ini files within my Y_INI based saving system will save on the host, an issue which I have not had with previous hosts. The script runs perfectly when on localhost, but when I register on the hosted server, it throws out an error, showing the following:
*** YSI Error: INI_Open could not find or create file /users/Test.ini
Before you ask, the 'users' folder exists, and I have tried to set the permissions of the folder in Filezilla (which did not work, although I believe this is due to the host being Windows-based). I have changed the user file path a number of times, including the following iterations:
#define PATH "/users/%s.ini"
#define PATH "users/%s.ini"
#define PATH "users\%s.ini"
#define PATH "\users\%s.ini"
I have also tried other folders as well, none of which were successful.

In addition to this, I also constantly receive this in my server_log on the host, which I have never seen before:
[09:11:37] [debug] Server crashed due to an unknown error
[09:11:37] [debug] Native backtrace:
[09:11:37] [debug] #0 0208d0a0 in ?? ()
[09:11:37] [debug] #1 00463349 in ?? () from samp-server.exe
[09:11:37] [debug] #2 770bfa39 in ?? () from C:\Windows\SysWOW64\ntdll.dll
[09:11:37] [debug] #3 770bfeae in ?? () from C:\Windows\SysWOW64\ntdll.dll
[09:11:37] [debug] #4 770c00b3 in ?? () from C:\Windows\SysWOW64\ntdll.dll
[09:11:37] [debug] #5 770bfd4f in ?? () from C:\Windows\SysWOW64\ntdll.dll
The most confusing aspect of it all, is that the SQLite-based saving (for houses, businesses, and such) works perfectly, causing no errors. I still have a few old, cfg-based saving systems, awaiting conversion too, which keep causing server crashes when the files automatically save.

What I have tried:
  • A SQLite-based saving script - Works perfectly
  • Reinstalling every file on the host. Twice.
  • Contacting the host - Unhelpful.
  • Changing parts of the script.
  • Countless other methods...(Cannot remember exactly)
I believe that this is NOT a script-related issue, although I can provide aspects of my code for authentication. If it matters, I am using the host "Vortex Servers", just in case anyone else has had the same issue, and knows of an easy way to fix this. It is weird since the same script worked perfectly a few months ago on a Linux VPS, and it is just having its issues right now. Again, it works perfectly on the localhost, but does not work on the Windows-based host. Help please?

List of plugins (If Relevant):
  • YSF
  • Whirlpool
  • Streamer
  • MapAndreas
  • Crashdetect

Forum Jump:

Users browsing this thread: 1 Guest(s)