0.3.7 "update" GameModeInit stopped working
#1

After I updated to 0.3.7 my server, OnGameModeInit stopped working for my VPS linux hosting. I started the gamemode under my PC at windows 8, it does work. I checked if it's from a plugin. Reinstalled all of them (sscanf, streamer, dns). Still it doesn't read "Mode" is Unknown. DisableInteriorEnterExits(); as well

My server.cfg
PHP код:
echo Executing Server Config...
lanmode 0
rcon_password lalalala123
maxplayers 200
port 7777
hostname ServerName
gamemode0 sed 1
filterscripts anims ACrash VehicleModProtection
announce 1
query 1
weburl sedbg
.info
onfoot_rate 40
incar_rate 40
weapon_rate 40
stream_distance 300.0
stream_rate 1000
maxnpc 0
plugins streamer
.so sscanf.so dns.so
logtimeformat 
[%H:%M:%S]
rcon 0
language Bulgarian 
The server VPS is debian
Reply
#2

Show us your change logs
Reply
#3

PHP код:
----------
Loaded log file"server_log.txt".
----------

SA-MP Dedicated Server
----------------------
v0.3.7, (C)2005-2015 SA-MP Team

[14:49:02
[
14:49:02Server Plugins
[14:49:02] --------------
[
14:49:02]  Loading pluginstreamer.so
[14:49:02

*** 
Streamer Plugin v2.7.5.2 by Incognito loaded ***

[
14:49:02]   Loaded.
[
14:49:02]  Loading pluginsscanf.so
[14:49:02

[
14:49:02]  ===============================

[
14:49:02]       sscanf plugin loaded.     

[
14:49:02]          Version:  2.8.1        

[14:49:02]    (c2012 Alex "******" Cole  

[14:49:02]  ===============================

[
14:49:02]   Loaded.
[
14:49:02]  Loading plugindns.so
[14:49:02

*** 
DNS Plugin v2.4 by Incognito loaded ***

[
14:49:02]   Loaded.
[
14:49:02]  Loaded 3 plugins.

[
14:49:02
[
14:49:02Ban list
[
14:49:02] --------
[
14:49:02]  Loadedsamp.ban
[14:49:02
[
14:49:02
[
14:49:02Filterscripts
[14:49:02] ---------------
[
14:49:02]   Loading filterscript 'anims.amx'...
[
14:49:02]   Loading filterscript 'ACrash.amx'...
[
14:49:02
--------------------------------------
[
14:49:02]  Loaded Small protection (v2.0against Exception 0xC0000005 at 0x7F120E
[14:49:02] --------------------------------------

[
14:49:02]   Loading filterscript 'VehicleModProtection.amx'...
[
14:49:02
--------------------------------------
[
14:49:02]  Vehicle Mod Protection by Jameskmonger and JernejL
[14:49:02] --------------------------------------

[
14:49:02]   Loaded 3 filterscripts.

[
14:49:02]  
[
14:49:02]  
[
14:49:02]  
[
14:49:02]  ======================================= 
[
14:49:02]  |                                     | 
[
14:49:02]  |        YSI version 3.09.0684        
[
14:49:02]  |        By Alex "******" Cole        
[
14:49:02]  |                                     | 
[
14:49:02]  ======================================= 
[
14:49:02]  
[
14:49:02]  
[
14:49:02]  
[
14:49:02]  .:: Street Energy Drift ::.
[
14:49:02Number of vehicle models
Reply
#4

My gamemode is working and is using 0.3.7 so it isn't the new versions problem, it's on your end.
Reply
#5

Check inside your gamemode if there are outdated callbacks/functions and update it with new 0.3.7 functions
Reply
#6

Yea, right it's from the gamemode, but why it's working under Windows, but it doesn't under linux.

PHP код:
#include <a_samp>
#include <Dini>
#include <YSI\y_ini>
#include <streamer>
#include <GetVehicleColor>
#include <fuckCleo>
#include <GPDID>
#include <foreach>
#include <sscanf2>
#include <dns>
#include <moneyprotect>
#pragma dynamic 20000000 
In the begin of my gamemode
Reply
#7

You sure you have the main() { } in your gamemode?
Reply
#8

I do
Reply
#9

How do you know OnGameModeInit is not being called? Are you sure it isnt something else?

Put a printf statement under ongamemodeinit at the very top to see if it is being called.

EDIT: I just re-read that you said unknown gamemode. Have you tried another gamemode to see?
Reply
#10

one thing I mind it's from the folders of the files.
PHP код:
#define House_File            "House/%d.ini"
#define FILE_FOR_PLAYER       "House/Player/%s.ini" 
The questioned house files are in /scriptfiles/House

The reason I think so at windows it's fully working, at the VPS hosting (Linux) is not.
Reply


Forum Jump:


Users browsing this thread: