[Help]Error foreach
#1

Hello
What is This Error ?
PHP код:
C:\Documents and Settings\Administrator\Desktop\NVCNR\NVCNR\NVCNR\pawno\include\YSI\y_iterate.inc(203) : fatal error 111user error"Old foreach.inc files are no longer compatible with YSI." 
Quote:

C:\Documents and Settings\Administrator\Desktop\NVCNR\NVCNR\NVCNR\p awno\include\YSI\y_iterate.inc(203) : fatal error 111: user error: "Old foreach.inc files are no longer compatible with YSI."

how To Fix it ?
Reply
#2

Update YSI and foreach, and try..
Reply
#3

Lets take a look at what happens when this error occurs.

pawn Код:
#if defined _inc_foreach
        #if !defined _FOREACH_CUR_VERSION
            // Foreach exists, but it's an old version - don't try use this
            // system or the variables will conflict.
            #error "Old foreach.inc files are no longer compatible with YSI."
            #endinput
        #endif
What it means is you have included the foreach standalone and also y_iterate you should only be including y_iterate.
Reply
#4

Quote:
Originally Posted by Pottus
Посмотреть сообщение
Lets take a look at what happens when this error occurs.

pawn Код:
#if defined _inc_foreach
        #if !defined _FOREACH_CUR_VERSION
            // Foreach exists, but it's an old version - don't try use this
            // system or the variables will conflict.
            #error "Old foreach.inc files are no longer compatible with YSI."
            #endinput
        #endif
What it means is you have included the foreach standalone and also y_iterate you should only be including y_iterate.
delete foreach.inc ? or what u mean
Reply
#5

Find and remove:
PHP код:
#include <foreach> 
Reply
#6

Quote:
Originally Posted by Jimmy0wns
Посмотреть сообщение
Find and remove:
PHP код:
#include <foreach> 
after i delete it still this problems :/
Quote:

F:\New Folder (2)\ffffffff\pawno\include\YSI\y_iterate.inc(203) : fatal error 111: user error: "Old foreach.inc files are no longer compatible with YSI."

Reply
#7

Help Please!!
Reply
#8

Bump
Reply
#9

First thing you cannot bump before 24 hrs , and update your includes
Reply
#10

http://forum.sa-mp.com/attachment.ph...3&d=1339499118

This Will help you
Reply


Forum Jump:


Users browsing this thread: