Problem with a linux server
#1

After i execute the samp binary on my linux server, i typed "netstat -an" to show all the current connections and the samp server isn't on LISTEN, but instead shows up like this:
udp 0 0 0.0.0.0:7777 0.0.0.0:*

and that's it.

It is supposed to listen on the public IP but it doesn't. Some other daemons such as DNS, ssh seem to work fine (of course, or else i wouldn't be able to remotely access it).


How do i start the server on the right interface?

Also, isn't there supposed to be a LISTEN ? It doesn't appear on netstat
Reply
#2

https://sampwiki.blast.hk/wiki/Linux_Server
Reply
#3

Quote:
Originally Posted by nateskywalker
what a genius.
Reply
#4

I know my server running

udp 0 0 0.0.0.0:7777 0.0.0.0:*
thats right!

use ifconfig to configure your networkinterface
a good linux server have not mor as 1networkinterface how many you have?
use ifconfig *your interface not use* down | to disable it

are you shure your servercfg is lanmode on 0 and announce 1 and on your router the port 7777 or somthing is a UDP Port!!!

if this dont work tell me your host.


Reply
#5

I know I'm not a noob and that if it was so easy to solve i wouldn't have asked. And no thank you, I don't need any basic linux question about how to see interfaces nor checking the config file.(that's stuff i learnt when i was 9 lol) .

And yeah, vpsland already informed me that they block all UDP ports on their routers.
Reply
#6

Oke Sorry Master



And yeah, vpsland already informed me that they block all UDP ports on their routers.

this fuckers
Reply


Forum Jump:


Users browsing this thread: