Unable to start server on port: 7777. Port in use?
#27

Quote:
Originally Posted by WILD33
View Post
не думаю,на 0.3а и 0.2х всё было путем,запускал также..сейчас запускаю через ./samp03svr & именно из за непоняток
ЗЫ что через start.sh что через ./samp03svr & сервер ведёт себя одинаково
предлагаю тебе вот такой вот проверенный временем вариант.. скрипт я назвал "samp03WatchingScript.sh". В папке серва должна быть папка "logs", туда будут складываться архивы логов..

Code:
#!/bin/sh

serverLog="server_log.txt"
bin="./samp03svr"

dat=`date`

cd /указываем/тут/папку/серва

while true; do
	mv ./${serverLog} ./logs/${serverLog}.`date '+%m%d%y%H%M%S'`
	echo "${dat} running sa-mp 0.3 server..." >> ${serverLog}
	${bin} >> ${serverLog}
	echo "${dat} sa-mp 0.3 server stoped, restarting..." >> ${serverLog}
	sleep 3
done
создаем скрипт, который у нас будет являться сервисом и будет лежать в папке "/etc/rc.d/init.d"

Code:
#!/bin/bash
#chkconfig: 234 60 50
#description: SA-MP 0.3 Server


# Source function library.
. /etc/rc.d/init.d/functions

# Source networking configuration.
. /etc/sysconfig/network

# Check that networking is up.
[ ${NETWORKING} = "no" ] && exit 0


server_start() {
	/путь/к/скрипту/samp03WatchingScript.sh & # put in full path and name of startup script
}

server_stop() {
	killall samp03WatchingScript.sh # your startup script name
	killall samp03svr # need to put in path to killall if its not in $PATH
#	killall samp-npc # need to put in path to killall if its not in $PATH
}

server_restart() {
	server_stop
	sleep 1
	server_start
}


# See how we were called.
case "$1" in
	'start')
		server_start
	;;
	'stop')
		server_stop
	;;
	'restart')
		server_restart
	;;
	*)
		echo "usage $0 start|stop|restart"
		exit 0
esac

exit 1
ну и стессна, надо добавить сервис в автозагрузку и запустить его
Reply


Messages In This Thread
Unable to start server on port: 7777. Port in use? - by WILD33 - 30.12.2010, 12:17
Re: Unable to start server on port: 7777. Port in use? - by SiJAYS_S - 30.12.2010, 12:38
Re: Unable to start server on port: 7777. Port in use? - by WILD33 - 30.12.2010, 12:55
Re: Unable to start server on port: 7777. Port in use? - by MX_Master - 30.12.2010, 14:29
Re: Unable to start server on port: 7777. Port in use? - by dimonml - 30.12.2010, 15:00
Re: Unable to start server on port: 7777. Port in use? - by Makar93 - 30.12.2010, 15:40
Re: Unable to start server on port: 7777. Port in use? - by Fro1sha - 30.12.2010, 15:47
Re: Unable to start server on port: 7777. Port in use? - by On1xS - 30.12.2010, 16:19
Re: Unable to start server on port: 7777. Port in use? - by Fro1sha - 30.12.2010, 16:36
Re: Unable to start server on port: 7777. Port in use? - by Stepashka - 30.12.2010, 16:43
Re: Unable to start server on port: 7777. Port in use? - by Fro1sha - 30.12.2010, 16:56
Re: Unable to start server on port: 7777. Port in use? - by Stepashka - 30.12.2010, 17:05
Re: Unable to start server on port: 7777. Port in use? - by Fro1sha - 30.12.2010, 17:06
Re: Unable to start server on port: 7777. Port in use? - by MX_Master - 30.12.2010, 17:10
Re: Unable to start server on port: 7777. Port in use? - by WILD33 - 31.12.2010, 05:56
Re: Unable to start server on port: 7777. Port in use? - by dimonml - 31.12.2010, 14:21
Re: Unable to start server on port: 7777. Port in use? - by MX_Master - 31.12.2010, 18:20
Re: Unable to start server on port: 7777. Port in use? - by toneysix - 31.12.2010, 18:39
Re: Unable to start server on port: 7777. Port in use? - by MX_Master - 01.01.2011, 04:02
Re: Unable to start server on port: 7777. Port in use? - by WILD33 - 01.01.2011, 08:35
Re: Unable to start server on port: 7777. Port in use? - by On1xS - 01.01.2011, 10:23
Re: Unable to start server on port: 7777. Port in use? - by WILD33 - 01.01.2011, 13:03
Re: Unable to start server on port: 7777. Port in use? - by dimonml - 01.01.2011, 14:10
Re: Unable to start server on port: 7777. Port in use? - by WILD33 - 01.01.2011, 15:09
Re: Unable to start server on port: 7777. Port in use? - by MX_Master - 01.01.2011, 15:45
Re: Unable to start server on port: 7777. Port in use? - by WILD33 - 01.01.2011, 16:22
Re: Unable to start server on port: 7777. Port in use? - by MX_Master - 01.01.2011, 17:19
Re: Unable to start server on port: 7777. Port in use? - by WILD33 - 02.01.2011, 07:26

Forum Jump:


Users browsing this thread: 1 Guest(s)