07.07.2015, 01:57
Quote:
The loop you're using ( for example if MAX_PLAYERS is set to 40), it will start from 40 and every time do -1 which means that it's going the opposite direction. That doesn't mean that you optimized it in a better way, like you stated in your post.
Anyway I might be wrong, misread Код:
Use the above if the order in which the code is executed does not matter. You can optimize that too further but I feel that it will reduce the readability of the code. Код:
for(new i = GetPlayerPoolSize();--i != -1;) {} |