15.11.2013, 16:28
Quote:
I think this look pretty good one thing I think could have been done differently is this.
Doing this looks ugly to me and doesn't really make sense given the way dialogs are organized with your include in this manner. pawn Code:
pawn Code:
|
I was thinking that "WeaponMenu" for example could be a real constant ID rather than a disguised string, so then I can do something like:
pawn Code:
public OnDialogReceived(playerid, dialog, response)
{
if (dialog == WeaponMenu)
{
// code
}
return 1;
}