Quote:
Originally Posted by MP2
First of all get off your high horse and realise I made a small mistake when editing SOMEONE ELSES code (Vincent's), and secondly szSuccess would be a better string name as 'string' 'polluted' the namespace.
It is not 'such a fail' - I made a small mistake in not changing the name of the string parameter in format(). You sir are a failure.
pawn Code:
CMD:vcolor(playerid, params[]) { if(GetPlayerState(playerid) != 2) return SendClientMessage(playerid, 0xFF0000FF, "You are not driving a vehicle."); new color[2]; if(sscanf(params, "iI(-1)", color[0], color[1])) { return SendClientMessage(playerid, 0xFF0000FF, "USAGE: /colorcar [color1] <color2>"); } if(color[1] == -1) color[1] = color[0]; // If color2 was left out, set it the same as color 1 new szSuccess[44]; format(szSuccess, sizeof(szSuccess), "Vehicle colors changed to: {FFFFFF}%i and %i.", color[0], color[1]); SendClientMessage(playerid, 0x00FF00FF, szSuccess); ChangeVehicleColor(GetPlayerVehicleID(playerid), color[0], color[1]); return 1; }
|
thanks!! and how can i add this in it?
pawn Code:
if(IsPlayerVipMember(playerid))
if they not vip member, they cannot change vehicle color and it will say "you have to be vip member!"