22.08.2011, 12:45
Should it now be like this:
Because in the menu it shows the price its going to cost, just fill where Amount.. is to the amount you want taking away, Its got to be Listitem right? Give that a try etc?
pawn Код:
if(listitem == 0):
{
GivePlayerWeapon(playerid,22,100);
GivePlayerMoney(playerid, -Amount..)
}
if(listitem == 1):
{
GivePlayerWeapon(playerid, 30, 1000);
GivePlayerMoney(playerid, -Amount..)
}
if(listitem == 2):
{
GivePlayerWeapon(playerid,31, 1000);
GivePlayerMoney(playerid, -Amount..)
}
if(listitem == 3):
{
GivePlayerWeapon(playerid,8, -1);
GivePlayerMoney(playerid, -Amount..)
}
}
Because in the menu it shows the price its going to cost, just fill where Amount.. is to the amount you want taking away, Its got to be Listitem right? Give that a try etc?