31.05.2009, 16:13
okay, so i had an idea, basically form a group, and what we will do is go through existing scripts/functions, and make them more efficient, or we will make our own functions and spread them through the community.
How To Join:
Simply fix this piece of code and post it here, you have too fix everything, unless stated otherwise. (it took me so long to make this, yet i see it everyday) NO cheating and looking at already posted fixes.
Note:as far as this goes "suppose" i have every function you use.
one of the things you could do was make a variable and assign the players name to that variable in OnPlayerConnect, but you don't have to do that to pass.
Projects: (you can propose projects, or work on them.)
Fix the GF script (In Progressaren_Jacobson, all 26243 lines of it!)
Fix functions that could be #defines too improve efficiency.
Go through Forums teaching people how too fix the code they post.
I was trying to figure out an acronym, and a name that goes with it, but it was too hard, so i i gave up, if you have one, post it!
i had this idea a long time ago, but i just barely realized how crazy this is getting.
How To Join:
Simply fix this piece of code and post it here, you have too fix everything, unless stated otherwise. (it took me so long to make this, yet i see it everyday) NO cheating and looking at already posted fixes.
pawn Код:
if(strcmp(cmd, "/command", true) == 0)
{
new tmp[256];
tmp = strtok(cmdtext, idx);
for(new i; i < GetMaxPlayers(); i++)
{
if(IsPlayerConnected(i))
{
new string[256], name[256];
GetPlayerName(playerid, name, sizeof(name))
format(string, sizeof(string), "%s typed a command with the extra param %s!", name, tmp);
SendClientMessage(playerid, 0xFFFFFFFF, string);
}
}
return 1;
}
one of the things you could do was make a variable and assign the players name to that variable in OnPlayerConnect, but you don't have to do that to pass.
Projects: (you can propose projects, or work on them.)
Fix the GF script (In Progressaren_Jacobson, all 26243 lines of it!)
Fix functions that could be #defines too improve efficiency.
Go through Forums teaching people how too fix the code they post.
I was trying to figure out an acronym, and a name that goes with it, but it was too hard, so i i gave up, if you have one, post it!
i had this idea a long time ago, but i just barely realized how crazy this is getting.